Print Page | Close Window

confirmation emails

Printed From: RomanCart.com Forum
Category: RomanCart
Forum Name: Integration
Forum Description: If you need help using RomanCart in your own website, post here.
URL: http://forums.romancart.com/forum_posts.asp?TID=13616
Printed Date: 19 December 2018 at 1:24am


Topic: confirmation emails
Posted By: peter.pwa
Subject: confirmation emails
Date Posted: 22 September 2017 at 11:29am
Hi, I have added my logo to the secure file section and copied the code into the header for the confirmation order email. This works fine.
The despatch email however does not show my logo and no longer sends me a confirmation email of the despatch email. I copied the exact same code for the confirmation order to the order despatch email so don't understand what I done wrong.
Any chance you can take a look please?
store 25978

thanks



Replies:
Posted By: peter.pwa
Date Posted: 26 September 2017 at 1:53pm
Oh this is so frustrating.
Support please? I'm not getting a copy of despatch emails and it's not being sent to customer by the looks of it. If you can't see any problem at least let me know!!
25978


Posted By: Support
Date Posted: 26 September 2017 at 3:49pm
Hi,
I checked on the system and it is working and your email is not bouncing back to us.
You need to speak to your email providers to find out where the email is going.
Try a different email at 'tools'/'options'/'email' e.g. a gmail account.
Many thanks
Support


Posted By: Support
Date Posted: 26 September 2017 at 3:51pm
Hi,
Having said that, I just double checked your despatched email header and you have used strange double quotes in it.
Change these for normal double quotes.
Paste the header into notepad and you will see what I mean.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 26 September 2017 at 4:04pm
Thanks.
It has the same double quotes in the order confirmation email code, The logo was put in your secure image bank and I copied the code from there.
As it worked ok on the test email, I used the same code for the logo in header of the despatch code. I use the same email addy for the order conf email and that arrives straight away. I tried another email addy but still diddnt work.


Posted By: peter.pwa
Date Posted: 26 September 2017 at 4:19pm
My confirmation emails arrive ok using the logo code in header.
%20" rel="nofollow - http://prntscr.com/gpy7i4
The despatch email does not arrive but when I view email it looks like this. no logo and no delivery addy.
%20" rel="nofollow - http://prntscr.com/gpy8pb


Posted By: Support
Date Posted: 26 September 2017 at 4:21pm
Hi,
You need to fix the quotes as that is an encoding issue when you cut and pasted.
Please fix that and then try it again.
Many thanks
Support


Posted By: peter.pwa
Date Posted: 26 September 2017 at 4:26pm
I did fix them on confirmation and on despatch emails. Still no joy.
those screenshots still is how it looks.


Posted By: Support
Date Posted: 26 September 2017 at 4:31pm
Hi,
You have the despatchaddress tag on it's own outside of the p tags.
You also have opened some p tags and not closed them.
I'm not sure if that's the problem, but sort those out, try it again and please let us know.

Many thanks
Support


Posted By: peter.pwa
Date Posted: 26 September 2017 at 5:04pm
Ok, Logo appears to be showing now, I had deleted the = in error after the <img scr..
All it is not doing now is sending me the confirmation email for the despatch email even though it is the same email that I'm using for the order confirmation which arrives instantly every time. I don't know if customers will get it. I have an order I put in myself as a test on the 10th July and using the send again despatch email nothing is getting to me from that order so I assume customers are not getting it either. As I said, I'm using the same email as the confirmation order email and that arrives ok.


Posted By: Support
Date Posted: 26 September 2017 at 7:14pm
Hi,

If your email is from you, to you then you won't receive it as your mailserver knows it didn't send it.
Many Thanks
Support


Posted By: peter.pwa
Date Posted: 26 September 2017 at 11:11pm
My email has not changed in 10 years. All I did was change the background from grey to white and add a new logo!
the order confirmation emails get to this email address ok, Why not the despatch emails.


Posted By: Support
Date Posted: 27 September 2017 at 8:54am
Hi,
As per our last post - if when you are testing it, you are effectively sending an email from you, to you, then your email server will probably reject it, as it did not know it has sent it.
Make sure with your test that you are using a completely different email address than what the email is set to be sent from.
Many Thanks
Support


Posted By: peter.pwa
Date Posted: 27 September 2017 at 10:09am
The order confirmation email gets to me fine. although not to the alternate BT email I have in there.
It's the despatch email not getting to me and I cant test that unless I resend a client one which I have done a few times, no emails are getting to me from there.
If you see something obvious that I'm doing wrong please tell me and I'll pay for a fix!!
Can't be doing with this it's too difficult I'm not a programmer you need to make these more user friendly. I'm rapidly losing the will to live!!!


Posted By: Support
Date Posted: 27 September 2017 at 10:11am
Hi,

Create a test order that you can dispatch using an email address other than the one you are using as the send address for the despatch email.
If you're not sure what this means, please call our support line from 11am this morning and we'll talk you through it.

Many thanks
Support


Posted By: peter.pwa
Date Posted: 27 September 2017 at 10:47am
Entered an order on my website. Used a BT email address that I know I receive emails on. I get a CONFIRM on PSP: confirmation email (whatever that means) and this goes to my peter@pwauk.com email.
I have not received an email confirmation order to my BT address that is shown on the order. %20" rel="nofollow - http://prntscr.com/gq99vc
I marked it as paid, then despatched it. No emails have arrived for the despatch email to either email..


Posted By: Support
Date Posted: 27 September 2017 at 10:50am
Hi,

That would be a different issue.
If you are not receiving either emails on your BT address, then this is something you will need to discuss with BT.
Unfortunately we cannot guarantee delivery of any emails as that is down to your email provider.
They will be removing them as junk or following some other rule on your BT email setup.

In the last few years BT are the most difficult email provider for this. Try using a gmail account or an address on a different email server.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 27 September 2017 at 10:53am
ok, if that is the case, why don't I get my copy merchant despatch confirmation email that is the same email I use for the order confirmation email which I do get?


Posted By: Support
Date Posted: 27 September 2017 at 10:59am
Hi,

I think it's probably best if you phone our support line, who will be able to clarify this.

To summarise the points.

1. Don't try an email from yourself, to yourself as your email server will reject it as it knows it did not send it.
2. We cannot guarantee delivery of emails. If you are not receiving emails with a particular host then it is something you need to discuss with them.
Every email host has different rules. They may need you to set up spf records on your dns for example or follow some other requirements they may have.

In general though we are very limited in how we can help with any email issues you may be having as we have no control over your email servers whomever you may be using for this service. The only thing we can check is whether the email was actually sent and whether it is bounced back. After that it is down to the target email server for delivery.

Many Thanks
Support



Print Page | Close Window