Print Page | Close Window

Cart image with scripts

Printed From: RomanCart.com Forum
Category: RomanCart
Forum Name: Integration
Forum Description: If you need help using RomanCart in your own website, post here.
URL: http://forums.romancart.com/forum_posts.asp?TID=13789
Printed Date: 05 December 2021 at 4:18am


Topic: Cart image with scripts
Posted By: peter.pwa
Subject: Cart image with scripts
Date Posted: 24 August 2021 at 2:12pm
Hello, I have an image of the cart, with scripts showing how many items and one with the total cost. This is on the sidebar of my pages. I now noticed that when I add something to the cart, it no longer stays on the page and takes me to the checkout. In options I have selected not to go to checkout.
Also, when I go back to the page, it has no items showing in the qty or total price. Has something changed? It has been a while since i set this up and not sure when this changed. Using MS Edge
this is the cart script..

          <img src="images/cart1.jpg" width="110" height="80"> </div>
        <p align="center"> You have (<font color="#009900">
          <SCRIPT LANGUAGE="JavaScript" SRC=" https://www.romancart.com/cartinfo.asp?storeid=*" rel="nofollow - https://www.romancart.com/cartinfo.asp?storeid=* ****&type=1"></SCRIPT>
          </font> ) Items<br>
          in your Basket <br>
          
          Sub Total<font color="#000000">...<pr></font><font color="#339900">
          <SCRIPT LANGUAGE="JavaScript" SRC=" https://www.romancart.com/cartinfo.asp?storeid=*" rel="nofollow - https://www.romancart.com/cartinfo.asp?storeid=* ****&type=5"></SCRIPT>
          </font><p></p><a href=" https://www.romancart.com/cart.asp?storeid=25978" rel="nofollow - https://www.romancart.com/cart.asp?storeid=*****" ><input style="border-left:1px solid #000000; border-top:1px solid #000000; border-right:1px solid #525252; border-bottom:1px solid #525252; background:#757B93; width:150px; height:20px; font-size:11px; color:#EEEEEE; padding-left:5px;" type="Submit" style="width: 110px;" value="CHECKOUT"></a>
        <p align="center">
        </td>
              </tr></table>



Replies:
Posted By: Support
Date Posted: 24 August 2021 at 2:24pm
hi,
Before you do anything you should modify your links / buttons so they use https not http.

Most browsers not treat http as unsafe so it is probably the cause of the issue you are experiencing.
See the bottom faq at
https://www.romancart.com/shopping-cart/faq/" rel="nofollow - https://www.romancart.com/shopping-cart/faq/

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 2:32pm
Thanks but they do have the https:// don't they?


Posted By: Support
Date Posted: 24 August 2021 at 2:36pm
Hi,
Actually - yes :) sorry about that!

The script in your post is not adding anything to the cart.
Perhaps post the link to the page where you see this issue.

Either way - just make sure you have set/posted the 'returnurl' param correctly.
Also make sure displaycart is set or posted to no.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 2:45pm
Thanks, here is the link.

https://www.pwauk.com/outdoor.htm" rel="nofollow - https://www.pwauk.com/outdoor.htm

It is set to no.

I pasted the return URL on another product/page (link below) for an A0 Fabric poster and it does return although still does not show items in basket on that page.

https://www.pwauk.com/studentfabric.htm" rel="nofollow - https://www.pwauk.com/studentfabric.htm

There are hundreds of products can this be done globally within a category?

The script in my first post only picks up what is in checkout. The add to basket buttin is on the calculator.


Posted By: Support
Date Posted: 24 August 2021 at 2:48pm
Hi,
Unfortunately both those links don't work, returning a frame page with 'support services' at the top and a sedo parking links page in the main frame.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 2:52pm
Oh, Please try again?


Posted By: Support
Date Posted: 24 August 2021 at 2:55pm
Hi,
That now works.
I went to https://www.pwauk.com/studentfabric.htm" rel="nofollow - https://www.pwauk.com/studentfabric.htm
added something to the basket.
It returned to https://www.pwauk.com/studentfabric.htm" rel="nofollow - https://www.pwauk.com/studentfabric.htm
Is that not what you are seeing?

btw - you should switch to the responsive cart template as it is a lot better.
'configure'/'appearance'/'hosted cart pages'/'shopping cart templates'/'standard templates'
Go to page 4.
Tick 'web' and 'mob' for the responsive template.
If you are using PayPal Commerce Platform then that't the only template it works with.
See https://youtu.be/WNHo3UogLqo" rel="nofollow - https://youtu.be/WNHo3UogLqo

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 3:04pm
Yes
on the studentfabric one. that is because i entered the url of that page into that product. Do I have to do that on all products or can it be done globally?

When it returned to the fabric page did you see the cart on the top right? did it have a Qty in there with the price? showing on the web page?


Posted By: Support
Date Posted: 24 August 2021 at 3:09pm
Hi,
Yes - the qty and price on the right worked fine.
If you are not giving each product the return url then it will try and work it out automatically.
Browsers have changed a lot in the last few years and there is a meta tag you need to add for this to work reliably (to each page).
See 'tools'/'options'/'basket'

We would recommend using the returnurl on each product but try the above for a possible simple fix.

If your qty and price on the right is unreliable then close all your browsers and start again as the cart will be getting confused if lots of carts are open.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 3:34pm
Sorry two problems.
I still can't see on the webpage( not the checkout page) the basket showing what Qty and Price is in the checkout. If i go to checkout yes i can see them. On the webpage, it doesn't show any data on the basket Icon ie qty and total.


Also, I selected the Responsive RC Theme like you suggested but I lost my Logo from the top! Been years since I edited these can you give me a clue how to add my logo at the top?
Thanks


Posted By: Support
Date Posted: 24 August 2021 at 3:39pm
Hi,
'configure'/'company logo' for your company logo.
See https://www.romancart.com/shopping-cart/how-it-works-examples/" rel="nofollow - https://www.romancart.com/shopping-cart/how-it-works-examples/
for how to add the qty and total onto your site.
You are using an old method...
It should still work though...
If not then it means you need to close all your browsers, maybe reboot your computer etc.
Try it on your phone or something on a completely different network.
Sometimes when merchants are testing the cart this can happen when it thinks multiple carts are open and doesn't know which one you want to use.

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 3:50pm
Ok thanks. If you can suggest a better method to show the cart on each page I'm all ears


Posted By: Support
Date Posted: 24 August 2021 at 3:51pm
Hi,

See https://www.romancart.com/shopping-cart/how-it-works-examples/" rel="nofollow - https://www.romancart.com/shopping-cart/how-it-works-examples/

Many Thanks
Support


Posted By: peter.pwa
Date Posted: 24 August 2021 at 4:33pm
Ok thanks for your help.
I still can't get it to show basket numbers even after using the ROC method.
I did however get the system I had working before by viewing in Firefox!! It must be something in MS Edge at least the version i got and the page returns now after inserting the metafile on each page.

I will now look at sorting the logo on the basket page. Hopefully I shouldn't bother you again. Cheers


Posted By: Support
Date Posted: 24 August 2021 at 5:01pm
Hi,
It definitely works for me in edge.
Your browser has probably got multiple tabs open with carts in or you have multiple edge's open or something similar.
(Or you have some unusual non-default settings in the browser stopping that from working)
Or maybe edge has cached an old version of the page - consider clearing the cache and cookies.
Many Thanks
Support



Print Page | Close Window