RomanCart.com Forum Homepage
Forum Home Forum Home > RomanCart > Announcements
  New Posts New Posts
  FAQ FAQ  Forum Search   Register Register  Login Login

Sage Pay Users

 Post Reply Post Reply Page  <123>
Author
Message
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 19 October 2012 at 3:39pm
Hi Richard,

Looking at the transaction below, there is nothing from our side which shows any issues with it at all.

Pretty much, the transaction is fine.

If there are any issues with the transaction in terms of how Roman Cart is displaying or interpreting the information from Sage Pay that is likely to be an issue at their side.

Roman Cart is a shopping cart designed to work to our protocols, if it's not doing something it is advertised as doing, it may be worth contacting them about it.

Additionally, I have attached a copy of our server logs for this successful payment, which shows there are no issues with it.

If you need any further information, please don't hesitate to get in touch.


Kind Regards,



Danny Graham
Customer Service Advisor

Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 19 October 2012 at 3:47pm
This is a shot of our confuguation

Any help?




(Exciting bits deleted !)

Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 10:43am
Any updates on this?

Richard
Back to Top
Support View Drop Down
RomanCart Team
RomanCart Team


Joined: 16 March 2004
Location: United Kingdom
Status: Offline
Points: 10602
Post Options Post Options   Thanks (0) Thanks(0)   Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 2:18pm
Hi,

From your description, it would seem that the customer gets to sage pay, centers and submits their card details but then it sounds like the sage pay system is hanging.

We have no errors in our logs at all relating to this, which means that the customer did not reach RomanCart - which is required for the RomanCart details to be updated with the outcome of the transaction.

The problem appears to be an intermittant failure of Sage Pay to send the customer to our successurl.

Please can you get your support contact at sage pay to forward us the log extracts showing the exact parameters they are sending to us at which url.

Many thanks
Support
Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 2:26pm
Yes I have the report ready to send you, please provide an email address to send to (or email me info@365drills.com) and I will send to you.

Yes I agree with the diagnosis.

To recap:

It appears that on at least 10 occations this month the customer has left the Roman Cart "Cart" and entered the Sage Pay payment system.

And then having paid, has not been returned to the Cart.

If you can send me that email address I will send over the file. Also I will send over the SagePay contact details too.
Back to Top
Support View Drop Down
RomanCart Team
RomanCart Team


Joined: 16 March 2004
Location: United Kingdom
Status: Offline
Points: 10602
Post Options Post Options   Thanks (0) Thanks(0)   Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 2:28pm
Hi,
Please send to support@romancart.com
Thanks
Support
Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 5:25pm
Hi Simon,

Thank you for your email, unfortunatly the transaction is older than three days. After three days our logs are removed. However to see what URL you are using you can run a showpost



In order for us to troubleshoot Romancart issues further please perform a showpost. Our showpost facility allows us to see exactly what transaction information you are attempting to register.

I cannot find any transactions on your account, Live or Test, so you will need to change the Purchase URL to be the following, and submit a transaction to our 'showpost' address.

https://test.sagepay.com/showpost/showpost.asp   

Your showpost will list what you have passed, how you have passed it and where you have passed it from (IP address). Once sent through it is only accessible on our systems, so you will need to call or reply by email with your vendor name and the time at which the POST was performed, so that we can let you know what is being passed to us.


Should you have any further queries please do not hesitate to contact us.

Kind Regards,



Sean Tait
Customer Service Advisor
SagePay
Back to Top
Support View Drop Down
RomanCart Team
RomanCart Team


Joined: 16 March 2004
Location: United Kingdom
Status: Offline
Points: 10602
Post Options Post Options   Thanks (0) Thanks(0)   Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 6:34pm
Hi,

The information we are sending SagePay is not the question here. The success url is the same for every transaction and is hardcoded.
We need to know where Sage Pay are trying to post to, which is information only they can supply.

Please let us know when you have this information and we will be able to investigate further.

As it stands it looks like Sage Pay is losing this information at their end.


Many Thanks
Simon
RomanCart Support

Edited by Support - 22 October 2012 at 6:42pm
Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 6:44pm
I have decided to shut down Sagepay.

In the next few weeks I will transfer over to Total Web Solutions Limited

Sage Pay are not that great (quite a few down times this year) and they are charging me 25+VAT (30pcm)

So I have decided to swap out to Total Web Solutions at 10 a month + VAT

I will complete the testing for TWS and then drop SagePay. Its not really good enough that their technical support is rubbish but at 30 a month (360 a year) you would think you would get gold plated service.

If they cant even email you direct for the information then how am I as a customer supposed to get the best service.

Give me 2 weeks and I will have Steamline sort out the merchant number.

R.
Back to Top
hazellr View Drop Down
Newbie
Newbie


Joined: 25 July 2011
Location: London
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote hazellr Quote  Post ReplyReply Direct Link To This Post Posted: 22 October 2012 at 7:05pm
Hi Richard,


As per the email sent by RomanCart, do you have any recent examples (within the last 3 days) of the problems you've been experiencing? If you can supply the VPSTxID/Sage Pay unique ID for any examples, I can get the full logs for the transaction and supply the information required by RomanCart.


I look forward to hearing from you again in due course.


Kind Regards,



Dan Carville
Customer Service Advisor

Sagepay
Back to Top
 Post Reply Post Reply Page  <123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.031 seconds.